Northern California Pipe Trades Trust Funds
for UA Local 342

1855 Gateway Blvd., Suite 350, Concord, CA 94520-8445
Phone: 925/356-8921 | Fax: 925/356-8938 | Toll Free: 800/780-8984 | E-Mail: tfo@ncpttf.com

Health and Welfare

The Northern California Pipe Trades Health and Welfare Plan provides Health and Welfare benefits for Active and Retired Participants and their eligible Dependents. The Health and Welfare Plan provides medical, prescription drug, dental, hearing aid and vision benefits. Click on the links below for important information.

Plan Information

Summary Plan Description Cover Letter
Summary Plan Description
Summary of Material Modifications (SMM)

Active Subsidized Self-Payment Rules
Appeals Procedures
Grandfathered Health Plan Notice
Health Reimbursement Account (HRA)
HRA Prepaid Benefits Debit Card - Benny Card Information and FAQ
HRA Appeals Procedures
Participant Self-Payment / Deduct Rates

Applications / Forms

 

Beneficiary Designation Form
Blue Shield PPO Medicare Rx Form
Change Request Form
Change Request Form (Dependent)
Domestic Partner Affidavit (Active Participants Only)

Enrollment / Change Forms

Jury Duty Application / Forms (Active Participants Only)

Please contact UA Local 342 at 925/686-5880 for questions on Jury Duty Benefits and/or to request an Application and the required tax forms.

Kaiser Permanente Senior Advantage (KPSA) Form
Protected Health Information (PHI) Form
Retiree Health and Welfare Benefits Application
Self-Payment Billing Statement

Benefit / Claims / Provider Information

Blue Shield PPO and HMO Benefit Summary
Delta Dental Benefit Summary
HRA Claim Form
Kaiser Benefit Summary (Active)
Kaiser Benefit Summary (Retiree: Medicare)
Kaiser Benefit Summary (Retiree: Non-Medicare)
Vision Service Plan (VSP) Benefit Summary (Active)
Vision Service Plan (VSP) Benefit Summary (Retired)

 

 

 

 

To view PDF files you will need the free Adobe™ Acrobat Reader®
Terms of Use | Privacy Statement
This site is best viewed with Internet Explorer 9.0 or higher, Firefox 1.5 or higher, Safari 2.0 or higher.